低版本VS新项目在VS2019没法一切正常编译程序的难题

这儿指的编译程序并不精确,仅仅为了更好地便捷表明。

今日刚装了VS2019想换一个新领域,开启原先新项目的情况下发觉很多出错,而新项目本来是没有问题的,惦记着是很有可能因为VS2019升級了c语言编译器(相匹配版本:

Microsoft.CodeDom.Providers.DotNetCompilerPlatform.2.0.0),网上搜索后了解解决方案,纪录在下。

难题表明

低版本VS项目在VS2019无法正常编译的问题 低版本 无法正常编译 VS2019 相关技巧  第1张

低版本VS项目在VS2019无法正常编译的问题 低版本 无法正常编译 VS2019 相关技巧  第2张

具体表现为:

不正确列表中很多 “打不开源代码”不正确資源列表中很多文档没法包括前2个难题造成的编码中难题(文件格式、种类申明、界定等)解决方案

关键缘故是软件开发平台工具集的缺少,VS2019不自动下载以前版本的工具集(安裝时未积极挑选得话)。

1、寻找所需工具集版本

解决方法→新项目特性→基本:服务平台工具集

低版本VS项目在VS2019无法正常编译的问题 低版本 无法正常编译 VS2019 相关技巧  第3张

照片中为处理后的页面,具体情况应是列表中有VS 2019(v142)和VS 201?(v140),且VS 201?后有(未安裝),201?指新项目本来开发环境

2、免费下载所需工具集

专用工具→获得专用工具和作用→能用→单独部件:向下翻寻找“c语言编译器、转化成专用工具和运作时”,在这其中挑选相匹配工具集

低版本VS项目在VS2019无法正常编译的问题 低版本 无法正常编译 VS2019 相关技巧  第4张

例如我缺少的是VS 2015(v140)

安裝后,在以前特性页面就可以挑选相匹配工具集

参照:https://www.wandouip.com/t5i207272/

到此这篇有关低版本VS新项目在VS2019没法一切正常编译程序的难题的文章内容就详细介绍到这了,大量有关VS2019没法一切正常编译程序低版本內容请搜索之前的文章内容或再次访问下边的类似文章期待大伙儿之后多多的适用!